Warning: Memcache::addserver() expects parameter 2 to be long, string given in /usr/home/rpc/domains/rpc.one.pl/public_html/libraries/joomla/cache/storage/memcache.php on line 84 AG241EUv2
 
 
AG241EUv2 Drukuj Email
Wpisany przez rpc   
poniedziałek, 05 października 2009 21:33

Instalacja OpenWRT na Modemie/Routerze LINKSYS AG241V2-EU - 8.09.2, trunk


UWAGA trunk:

Poniższy opis dotyczy Kamikadze. Na trunku (r31576) działa ale trzeba zrobić małą modyfikację a dokładnie powiedzieć eth0 że jest podniesiony.

do pliku /etc/rc.local należy dopisać:

/usr/sbin/mii-tool -F 100baseTx-FD eth0

WYMAGANE skompilowanie pakietu mii-tool

Network->mii-tool

Pewnie można bardziej elegancko ale najważniejsze że działa.



1. Parametry modemu ADSL2

Modem ADSL 2/2+ 24MB (1xRJ11)
Switch 4-portowy (4xRJ45)
WIFI: Brak
Bootloader: PSPBoot
CPU: Texas Instruments AR7

Port szeregowy TTL (opis na laminacie JP4):

Pin 1: GND (pin od strony diody led)
Pin 2: nieużywany
Pin 3: RX
Pin 4: TX
Pin 5: VCC

parametry portu RS: 38400, 8N1


Więcej na stronie http://wiki.openwrt.org/OpenWrtDocs/Hardware/Linksys/AG241

2.Kompilacja openwrt dla AG241V2-EU

Kompilowałem z wersji 8.09.2  w debianie lenny
a. Potrzebujemy następujących pakietów:


apt-get install build-essential bison flex gettext subversion libncurses-dev unzip automake zlib1g-dev gawk


a. na linuksa logujemy się na konto użytkownika nie roota
b. zakładamy katalog np. mkdir ag241 i przechodzimy do tego katalogu
c. wydajemy następujące komendy:


svn co svn://svn.openwrt.org/openwrt/branches/8.09
cd 8.09
./scripts/feeds update -a
./scripts/feeds install -a
make menuconfig


d. minimalnie musimy wybrać następujące opcje:

Target System [TI AR7 [2.6]]
Target Profile [no WIFI]
Target Images [squashfs]

Oprócz domyślnie wybranych opcji zaznaczamy jeszcze dodatkowo:

Base system → br2684ctl
Network → atm-tools
Network → ppp → ppp-mod-pppoa
Network → ppp → ppp-mod-pppoe – jeśli ktoś będzie z tego korzystał
Kernel modules → Network Devices ->kmod-sangam-atm-annex-a
Kernel modules → Network support → kmod-ipoa

Odznacz (modem nie ma przecież wifi) opcję:

Kernel modules -> Wireless drivers -> kmod-acx


Te parametry lepiej w kompilować na stałe do kernela. Inne opcje do kompilacji wedle swojego uznania
zapisujemy zmiany w make menuconfig
kompilujemy komendą make V=99

Po kompilacji zostanie utworzony katalog „bin” w nim będą jąderka dla poszczególnych routerów. Na interesuje kernel:

openwrt-AG241v2-squashfs.bin

Jak podejrzymy go w edytorze nagłówek jego jest: AG3APBOT U2NDD. To jest kernel do AG241V2-EU

3. Wgrywanie openwrt do AG241V2-EU


Do wgrania używamy klienta tftp oraz PSPBoot na routerze Linksys czyli:

a.Wyłączamy router ag241 i podłączamy kablem ethernet z komputerem. Router czyli PSPBoot w czasie startu posiada adres ip 192.168.1.1 oraz maskę 255.255.255.0
b. na debianie ustawiamy statyczny adres interfejsu na np. 192.168.1.2 zakładamy że nasz lan to eth0
ifconfig eth0 192.168.1.2 netmask 255.255.255.0
c. zmień nazwę kernela z openwrt-AG241v2-squashfs.bin na upgrade_code.bin
d. wydaj komendę tftp w katalogu w którym jest umieszczony kernel openwrt i wpisz następujące opcje:


tftp> verbose
tftp> trace
tftp> rexmt 1
tftp> timeout 5
tftp> binary
tftp> connect 192.168.1.1


e. wpisz jeszcze jedną komendę ale NIE potwierdzaj enterem tylko czekaj:


tftp> put upgrade_code.bin


f. włącz router i jak tylko dioda power się zaświeci od razu potwierdź przygotowaną komendę enterem
g. Jeśli na ekranie pojawi się coś podobnego jak poniżej

....
sent DATA
received ACK
...

to znaczy że openwrt się wgrywa po tftp. Poczekaj aż skończą się wyświetlać te znaczki router SAM się zrestartuje. Dioda power zacznie migać na czerwono i zielono (nie przejmuj się wszystko jest ok. to openwrt tak steruje diodą) Poczekaj na wszelki wypadek jeszcze chwilkę.
h. Logujesz się do routera poprzez telnet czyli telnet 192.168.1.1 i zgłasza się openwrt


BusyBox v1.11.2 (2010-01-18 18:09:40 CET) built-in shell (ash)
Enter 'help' for a list of built-in commands.

_______                     ________        __
|       |.-----.-----.-----.|  |  |  |.----.|  |_
|   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
|_______||   __|_____|__|__||________||__|  |____|
|__| W I R E L E S S   F R E E D O M
KAMIKAZE (8.09.2, r18961) -------------------------
* 10 oz Vodka       Shake well with ice and strain
* 10 oz Triple sec  mixture into 10 shot glasses.
* 10 oz lime juice  Salute!
---------------------------------------------------


4. Konfiguracja Routera ADSL

root@OpenWrt:~# cat /etc/config/network

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0

config interface wan
# PPPoA:
option ifname ppp0
option unit 0
option proto pppoa
option encaps vc
option vpi 0
option vci 35
option keepalive 5,5
# Both:
option username "xxxxxxx"
option password "xxxxxxxx"


Aby modem automatycznie logował (+ sposób na mały bajer z diodą power) się do internetu należy zmodyfikować plik /etc/rc.local

vi /etc/rc.local

i uzupełniamy :

sleep 5
sh /etc/ppp/ip-down.d/89-leds
sleep 30
ifup wan &
exit 0


Należy jeszcze utwożyć 2 pliki:

touch /etc/ppp/ip-up.d/89-leds

o zawartości:

#!/bin/sh
echo default-on > /sys/devices/platform/leds-gpio/leds/status/trigger
echo 0 > /sys/devices/platform/leds-gpio/leds/status/brightness
exit 0


oraz utworzyć plik:

touch /etc/ppp/ip-down.d/89-leds

o zawartości

#!/bin/sh
echo default-on > /sys/devices/platform/leds-gpio/leds/status/trigger
echo 2 > /sys/devices/platform/leds-gpio/leds/status/brightness


Oraz wykonać następujące komendy

chmod +x /etc/ppp/ip-up.d/89-leds

chmod +x /etc/ppp/ip-down.d/89-leds


Ten bajer z led polega na tym, że jak jest internet to świeci dioda power na zielono, jesli internetu brak to miga na czerwono.


Konfiguracja routera w trybie Modem ADSL/Bridge (jeśli chcemy aby router robił tylko za modem w mode bridge 1483)

Plik /etc/config/network winien wyglądać następująco:

config interface loopback
option ifname   lo
option proto    static
option ipaddr   127.0.0.1
option netmask  255.0.0.0

config interface lan
option ifname   'eth0 nas0'
option proto    static
option type     bridge
option ipaddr   192.168.11.1
option netmask  255.255.255.0

config atm-bridge
option atmdev   0
option unit     0
option encaps   vc
option vpi      0
option vci      35
option payload  bridged


Teraz router pracuje w trybie bridge tylko jako modem. Bierzemy drugi router i łączymy się z internetem po protokole PPPOE. Oczywiście modem z routerem łączymy kablem ethernet.

Ps. Dobrze wyłączyć dhcp czyli (po co siać dhcp do tepsy czy netii)

/etc/init.d/dnsmasq disable
/etc/init.d/dnsmasq stop


I to już wszystko. Router za każdym razem uruchamia się poprawnie.

Działająca wersja OpenWrt 8.09.2 dla modemu AG241V2-EU do pobrania z mojego repozytorium

OpenWrt skompilowany w wersji podstawowej dodatkowo z: updateadd dla dyndns, miniupnp.



Podziel się tą informacja z innymi:
Poprawiony: niedziela, 10 lutego 2013 11:39