Warning: Memcache::addserver() expects parameter 2 to be long, string given in /usr/home/rpc/domains/rpc.one.pl/public_html/libraries/joomla/cache/storage/memcache.php on line 84 Cisco 1841 z dostępem do internetu poprzez pppoa
 
 
Cisco 1841 z dostępem do internetu poprzez pppoa Drukuj Email
Wpisany przez rpc   
czwartek, 28 lipca 2011 20:39

Cisco 1841 z dostępem do internetu poprzez pppoa


1.Założenia

Interfejs ADSL/ATM 0/0/0 (WIC-1ADSL) - wyjście do internetu (PVC 0/35, ITU G.992.1 Annex A).
Interfejs FastEthernet 0/1 - wyjście dla naszej sieci LAN
Adres przydzielanie dynamicznie od dostawcy internetu np. tpsa, neti
Adres sieci LAN to 192.168.1.0/24 (maska 255.255.255.0)
Adres routera od strony sieci LAN to 192.168.1.1
Podstawowa konfiguracja list ACL (firewall) blokująca ruch z WAN (z wyjątkiem ssh).
Podstawowa konfiguracja list ACL blokująca ruch z LAN do WAN pakietów sieci Microsoft Network (blokowanie portów 135-139).
Podstawowa konfiguracja list ACL blokująca ruch z LAN do WAN do portu 25 (smtp). Czyli prosta blokada wysyłania spamu poprzez wirusy z naszej sieci LAN.


Karta WIC-1ADSL wspiera niżej wymienione modulacje:

ansi-dmt      ANSI T1.413
auto          auto detect mode
itu-dmt       ITU G.992.1 Annex A
splitterless  ITU G.992.2 G.lite mode

W moim wypadku jest to internet z netii po linii tp. Mogę więc ustawić tryb auto albo itu-dmt. Ja wolałem na stałe ustawić bo modem szybciej się synchronizuje.


2.Konfiguracja PPPOA (WAN)

Do samej konfiguracji PPPOA interfejsu ATM wystarczą poniższe wpisy:

interface ATM0/0/0
description Placzenie WAN do internetu po ADSL
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
no atm ilmi-keepalive
dsl operating-mode itu-dmt
pvc 0/35
encapsulation aal5mux ppp dialer
dialer pool-member 1

Czyli definiujemy modulację oraz parametry PVC. Podłączamy również pod interfejs Dialer który będzie nas autoryzował, i który będzie tworzył połączenie po protokole ppp - krótko mówiąc to on się nam wdzwania.


Musimy jeszcze zdefiniować Dialer, który będzie tworzył link protokołu ppp do dostawcy netu:

interface Dialer1
description Dzwonimy do naszego ISP poprzez iface ATM pppoa
ip address negotiated
ip access-group ruch_z_wan in
no ip unreachables
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname internet
ppp chap password internet
ppp ipcp dns request
ppp ipcp route default
no cdp enable


3.Konfiguracja naszej sieci LAN:

interface FastEthernet0/1
description Lacze dla LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip verify unicast reverse-path
duplex auto
speed auto


4.Konfiguracja list ACL (firewall)

ip access-list extended ruch_z_lan
deny   tcp any any eq smtp
deny   tcp any any range 135 139
deny   udp any any range 135 netbios-ss
deny   tcp any range 135 139 any
deny   udp any range 135 netbios-ss any
permit ip 192.168.1.0 0.0.0.255 any
deny   ip any any
ip access-list extended ruch_z_wan
permit udp any eq domain any
permit icmp any any
permit tcp any any established
permit tcp any any eq 2122
permit tcp any any eq www
deny   ip any any


5.Konfiguracja NAT

ip nat inside source list ruch_z_lan interface Dialer1 overload
ip nat inside source static tcp 192.168.1.20 80 interface Dialer1 80
ip route 0.0.0.0 0.0.0.0 Dialer1


6.Konfiguracja DHCP

ip dhcp excluded-address 192.168.1.10 192.168.1.199
!
ip dhcp pool 192.168.1.0/24
network 192.168.1.0 255.255.255.0
domain-name rpc.dyndns.biz
default-router 192.168.1.1
dns-server 192.168.1.1
lease 0 1
!
ip dhcp pool 192.168.1.100/24
host 192.168.1.100 255.255.255.0
client-identifier 0100.1cc4.c81e.28
client-name rpc-xp
lease 0 0 30


7.Pełna konfiguracja może wyglądać następująco:

!
version 15.1
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname c-rpc
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$CI0Q$3doC35g/t1i22rVdOlLYB2
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
!
clock summer-time UTC recurring last Sun Mar 2:00 last Sun Oct 3:00
dot11 syslog
ip source-route
!
!
!
ip dhcp excluded-address 192.168.1.10 192.168.1.199
!
ip dhcp pool 192.168.1.0/24
network 192.168.1.0 255.255.255.0
domain-name rpc.dyndns.biz
default-router 192.168.1.1
dns-server 192.168.1.1
lease 0 1
!
ip dhcp pool 192.168.1.100/24
host 192.168.1.100 255.255.255.0
client-identifier 0100.1cc4.c81e.28
client-name rpc-xp
lease 0 0 30
!
!
ip cef
no ip bootp server
ip domain name rpc.dyndns.biz
ip host rpc.dyndns.biz ns ns1.rpc.dyndns.biz
ip host c-rpc.rpc.dyndns.biz 192.168.1.1
ip host ns1.rpc.dyndns.biz 192.168.1.1
ip ddns update method rpc.dyndns.biz
HTTP
add http://rpc:123456@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
interval maximum 1 0 0 0
!
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
!
!
username rpc privilege 15 secret 5 $1$/iyP$dr4t2Y0T3R6I6.ckAdJX3.
!
redundancy
!
!
ip tcp selective-ack
ip tcp timestamp
ip tcp path-mtu-discovery
ip ssh authentication-retries 4
ip ssh port 2222 rotary 1
ip ssh rsa keypair-name rpc
ip ssh logging events
ip ssh stricthostkeycheck
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
description Lacze dla LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip verify unicast reverse-path
duplex auto
speed auto
!
interface ATM0/0/0
description Placzenie WAN do internetu po ADSL
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
no atm ilmi-keepalive
dsl operating-mode itu-dmt
pvc 0/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface Dialer1
description Dzwonimy do naszego ISP poprzez iface ATM pppoa
ip ddns update hostname rpc.dyndns.biz
ip ddns update rpc.dyndns.biz
ip address negotiated
ip access-group ruch_z_wan in
no ip unreachables
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname internet
ppp chap password internet
ppp ipcp dns request
ppp ipcp route default
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip dns server
ip dns primary rpc.dyndns.biz soa ns1.rpc.dyndns.biz rpc.rpc.dyndns.biz 21600 900 7776000 86400
ip nat inside source list ruch_z_lan interface Dialer1 overload
ip nat inside source static tcp 192.168.1.20 80 interface Dialer1 80
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip access-list extended ruch_z_lan
deny   tcp any any eq smtp
deny   tcp any any range 135 139
deny   udp any any range 135 netbios-ss
deny   tcp any range 135 139 any
deny   udp any range 135 netbios-ss any
permit ip 192.168.1.0 0.0.0.255 any
deny   ip any any
ip access-list extended ruch_z_wan
permit udp any eq domain any
permit icmp any any
permit tcp any any established
permit tcp any any eq 2222
permit tcp any any eq www
deny   ip any any
!
logging esm config
!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
rotary 1
transport input ssh
!
scheduler allocate 20000 1000
end


Poprawiony: poniedziałek, 01 sierpnia 2011 11:52