Warning: Memcache::addserver() expects parameter 2 to be long, string given in /usr/home/rpc/domains/rpc.one.pl/public_html/libraries/joomla/cache/storage/memcache.php on line 84 Dyndns w cisco 1841 z pppoe
 
 
Dyndns w cisco 1841 z pppoe Drukuj Email
Wpisany przez rpc   
czwartek, 23 czerwca 2011 18:07

Dyndns w cisco 1841 z pppoe


Jeśli mamy podłączony nasz router do internetu poprzez PPPOE, PPPOA lub np. poprzez DHCP to często otrzymujemy adres dynamiczny. Znaczy się nigdy nie możemy przewidzieć jaki adres otrzymamy od swojego dostawcy. W związku z tym jeśli tylko chcemy dostać się z internetu do naszego routera to mamy problem. Jednym z rozwiązań jest skorzystanie z serwisy DDNS czyli powiązanie adresu domenowego z adresem IP, który zmienia się dynamicznie. Poniższa konfiguracja trochę nam tą sprawę ułatwi. Ja skorzystam z serwisu dyndns.


Założenia

Mamy już skonfigurowane połączenie PPPOE na interfejsie FastEthernet 0/0

Mamy już skonfigurowaną sieć  LAN na interfejsie FastEthernet 0/1

domena to: rpc.dyndns.biz

nazwa użytkownika w serwisie dyndns: rpc

hasło użytkownika w serwisie dyndns: 123456


Podstawowa konfiguracja:

Do globalnej konfiguracji musimy dopisać dokładnie poniższe wpisy:

ip ddns update method rpc.dyndns.biz
HTTP
add http://rpc:123456@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
interval maximum 1 0 0 0


Do interfejsu Dialler dopisujemy poniższą konfigurację:

ip ddns update hostname rpc.dyndns.biz
ip ddns update rpc.dyndns.biz


Pełna przykładowa konfiguracja może wyglądać następująco:


!
version 15.1
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname c-rpc
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$CI0Q$3$$od35g/t1i2$$2rVdOlLYB2
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
!
clock summer-time UTC recurring last Sun Mar 2:00 last Sun Oct 3:00
dot11 syslog
ip source-route
!
!
!
ip dhcp excluded-address 192.168.1.10 192.168.1.199
!
ip dhcp pool 192.168.1.0/24
network 192.168.1.0 255.255.255.0
domain-name rpc.dyndns.biz
default-router 192.168.1.1
dns-server 8.8.8.8
lease 0 1
!
ip dhcp pool 192.168.1.100/24
host 192.168.1.100 255.255.255.0
client-identifier 0100.1cc4.c81e.28
client-name rpc-xp
lease 0 0 30
!
!
ip cef
no ip bootp server
ip domain name rpc.dyndns.biz
ip ddns update method rpc.dyndns.biz
HTTP
add http://rpc:123456@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
interval maximum 1 0 0 0
!
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
!
!
username rpc privilege 15 secret 5 $1$/iyP$dr4t2Y0T3R6I6.ckAdJX3.
!
redundancy
!
!
ip tcp selective-ack
ip tcp timestamp
ip tcp path-mtu-discovery
ip ssh authentication-retries 4
ip ssh port 2222 rotary 1
ip ssh rsa keypair-name rpc
ip ssh logging events
ip ssh stricthostkeycheck
!
!
!
!
!
!
!
interface FastEthernet0/0
description Lacze do modemu adsl po ethernecie
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet0/1
description Lacze dla LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip verify unicast reverse-path
ip tcp adjust-mss 1452
duplex auto
speed auto
!
interface Dialer1
description Polaczenie pppoe
ip ddns update hostname rpc.dyndns.biz
ip ddns update rpc.dyndns.biz
ip address negotiated
ip access-group ruch_z_wan in
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname internet
ppp chap password internet
ppp ipcp dns request
ppp ipcp route default
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list ruch_z_lan interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip access-list extended ruch_z_lan
deny   tcp any any eq smtp
deny   tcp any any range 135 139
deny   udp any any range 135 netbios-ss
deny   tcp any range 135 139 any
deny   udp any range 135 netbios-ss any
permit ip 192.168.1.0 0.0.0.255 any
deny   ip any any
ip access-list extended ruch_z_wan
permit udp any eq domain any
permit icmp any any
permit tcp any any established
permit tcp any any eq 2222
deny   ip any any
!
logging esm config
no cdp run

!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
rotary 1
transport input ssh
!
scheduler allocate 20000 1000
end


.


Poprawiony: poniedziałek, 01 sierpnia 2011 11:53