Warning: Memcache::addserver() expects parameter 2 to be long, string given in /usr/home/rpc/domains/rpc.one.pl/public_html/libraries/joomla/cache/storage/memcache.php on line 84 Własny DNS dla sieci LAN na Cisco 1841 z pppoe
 
 
Własny DNS dla sieci LAN na Cisco 1841 z pppoe Drukuj Email
Wpisany przez rpc   
czwartek, 23 czerwca 2011 18:36

Własny DNS dla sieci LAN na Cisco 1841 z pppoe


Chcemy aby nasz router był dla naszych hostów serwerem DNS a nie jakiś serwer w internecie. Dodatkowo dostajemy adres dynamicznie i chcemy korzystać z dns przypisanych od dostawcy internetu. Jedną z możliwości jest nasz własny DNS na Cisco. Rozwiązanie przedstawione poniżej:


Założenia:

Nazwa routera: c-rpc

Adres IP routera: 192.168.1.1

Adres sieci LAN: 192.168.1.0/24

Nazwa domeny: rpc.dyndns.biz

Logowanie do internetu poprzez PPPOE na interfejsie FastEthernet 0/0 oraz Dialler 1

Sieć LAN na interfejsie FastEthernet 0/1


Konfiguracja DHCP:

ip dhcp excluded-address 192.168.1.10 192.168.1.199
!
ip dhcp pool 192.168.1.0/24
network 192.168.1.0 255.255.255.0
domain-name rpc.dyndns.biz
default-router 192.168.1.1
dns-server 192.168.1.1
lease 0 1
!

Wskazano dla hostów w naszej sieci adres IP naszego routera jako serwera dns.


Konfiguracja DNS:

ip domain name rpc.dyndns.biz
ip host rpc.dyndns.biz ns ns1.rpc.dyndns.biz
ip host c-rpc.rpc.dyndns.biz 192.168.1.1
ip host ns1.rpc.dyndns.biz 192.168.1.1
ip dns server
ip dns primary rpc.dyndns.biz soa ns1.rpc.dyndns.biz rpc.rpc.dyndns.biz 21600 900 7776000 86400

Może po koleii:

  1. Nazwa domeny to rpc.dyndns.biz
  2. Utworzono rekord NS czyli wskazano, że domena rpc.dyndns.biz jest obsługiwana przez serwer ns1.rpc.dyndns.biz
  3. Przypisano adres IP 192.168.1.1 do nazwy hosta c-rpc.rpc.dyndns.biz
  4. Przypisano adres IP 192.168.1.1 do nazwy hosta ns1.rpc.dyndns.biz
  5. Uruchomiono server DNS na routerze Cisco
  6. Utworzono rekord SOA. Czyli tworzymy naszą strefę do domeny rpc.dyndns.biz. Serwer DNS jest przedstawiany jako autorytatywny czyli taki, który obsługuje skonfigurowaną domenę.


Pełna konfiguracja może wyglądać następująco:


!
version 15.1
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname c-rpc
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$CI0Q$3doC35g/t1i22rVdOlLYB2
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
!
clock summer-time UTC recurring last Sun Mar 2:00 last Sun Oct 3:00
dot11 syslog
ip source-route
!
!
!
ip dhcp excluded-address 192.168.1.10 192.168.1.199
!
ip dhcp pool 192.168.1.0/24
network 192.168.1.0 255.255.255.0
domain-name rpc.dyndns.biz
default-router 192.168.1.1
dns-server 192.168.1.1
lease 0 1
!
ip dhcp pool 192.168.1.100/24
host 192.168.1.100 255.255.255.0
client-identifier 0100.1cc4.c81e.28
client-name rpc-xp
lease 0 0 30
!
!
ip cef
no ip bootp server
ip domain name rpc.dyndns.biz
ip host rpc.dyndns.biz ns ns1.rpc.dyndns.biz
ip host c-rpc.rpc.dyndns.biz 192.168.1.1
ip host ns1.rpc.dyndns.biz 192.168.1.1
ip ddns update method rpc.dyndns.biz
HTTP
add http://rpc:123456@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
interval maximum 1 0 0 0
!
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
!
!
username rpc privilege 15 secret 5 $1$/iyP$dr4t2Y0T3R6I6.ckAdJX3.
!
redundancy
!
!
ip tcp selective-ack
ip tcp timestamp
ip tcp path-mtu-discovery
ip ssh authentication-retries 4
ip ssh port 2222 rotary 1
ip ssh rsa keypair-name rpc
ip ssh logging events
ip ssh stricthostkeycheck
!
!
!
!
!
!
!
interface FastEthernet0/0
description Lacze do modemu adsl po ethernecie
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet0/1
description Lacze dla LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip verify unicast reverse-path
ip tcp adjust-mss 1452
duplex auto
speed auto
!
interface Dialer1
description Polaczenie pppoe
ip ddns update hostname rpc.dyndns.biz
ip ddns update rpc.dyndns.biz
ip address negotiated
ip access-group ruch_z_wan in
no ip unreachables
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname internet
ppp chap password internet
ppp ipcp dns request
ppp ipcp route default
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip dns server
ip dns primary rpc.dyndns.biz soa ns1.rpc.dyndns.biz rpc.rpc.dyndns.biz 21600 900 7776000 86400
ip nat inside source list ruch_z_lan interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip access-list extended ruch_z_lan
deny   tcp any any eq smtp
deny   tcp any any range 135 139
deny   udp any any range 135 netbios-ss
deny   tcp any range 135 139 any
deny   udp any range 135 netbios-ss any
permit ip 192.168.1.0 0.0.0.255 any
deny   ip any any
ip access-list extended ruch_z_wan
permit udp any eq domain any
permit icmp any any
permit tcp any any established
permit tcp any any eq 2222
deny   ip any any
!
logging esm config
no cdp run

!
!
!
!
!
!
!
control-plane
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
rotary 1
transport input ssh
!
scheduler allocate 20000 1000
end


Poprawiony: poniedziałek, 01 sierpnia 2011 09:00